Archive for July, 2007

24/7

This server has been online for about 4-5 days now, and 24/7 from now on untill something goes wrong 😀 So for now I’ve just left everything untouched, and there has been no trouble other than my dns stopped working for about 2 hours untill I repointed my ip to it…

Advertisements

Webmin

Surfed to this website, which I found very easy to follow, and on which I found reference to something amazing. Even though I had my basic LAMP server up and running, I found something more to include. I decided to install Webmin, which is a free server control panel.

Their website had a Debian package that made things relatively easy. Surprisingly enough, everything installed perfectly, and I though something was wrong since I didn’t have to configure anything 😀 However, when I tried to access the url to the panel from my Winxp pc, nothing seemed to work. So I tested https://localhost:10000 (Webmin port) from the server box, and it worked. Even though Webmin couldn’t be accessed from anywhere else then my server itself, the holy grail of server control was presented to me! Webmin isn’t just any kind of connection between you and your server, it’s much more. You can play around with your whole linux installation, for example it has a command line and download/upload function, which basically means I could ditch puTTy and Filezilla for good.

So this meant that even though I could only reach Webmin from one location, I wouldn’t let that put me down, since now I had more motivation than ever to make things work. Then after a long while of pondering, I realized the obvious… my router wasn’t letting anything go through port 10000. So I forwarded the port and then with a nervous right hand finger clicked refresh in my browser. I felt extremely relaxed when my browser asked if I wanted to accept the websites’ ssl certificate, which I did, and then I was flying past login to the kick-ass control panel 😛

FIN

New blog on new server!

Just testing out a bunch of stuff like this blog on my debian etch server box 😀 Everything is working, and I’m accessing the server through putty (the ssh client) and filezilla, both installed on my winxp pc.